Excel: Bedingte Formatierung zeilenweise wirken lassen – schnell erledigt!

Wenn Sie in Excel mehrere oder alle Zellen zeilenweise mit derselben bedingten Formatierung versehen möchten, müssen Sie vor allem einen Sache beachten. Hier lesen Sie, worauf es ankommt.

So wenden Sie die bedingte Formatierung auf mehrere Zellen einer Zeile an

  1. Angenommen, Sie haben eine einfache Tabelle, die die täglichen Arbeitsstunden von drei Mitarbeitern enthält. Sie möchten durch Einfärbung der jeweiligen Zeile schnell die Tage sehen, an denen die Personen insgesamt unter 20 Stunden gearbeitet haben.

    Beispiel für eine Aufstellung von Arbeitsstunden
    Beispiel für eine Aufstellung von Arbeitsstunden
  2. Markieren Sie dazu im Beispiel den Bereich von A2 bis D8. Das sind alle Zellen, die farblich unterlegt sein sollen falls die festgelegte Stundengrenze unterschritten wird.
  3. Klicken Sie Menüband Start auf das Icon Bedingte Formatierung.
  4. Wählen Sie als Option Neue Regel aus.
  5. Unter Windows geben Sie dann als Regeltyp vor: Formel zur Ermittlung der zu formatierenden Zellen verwenden. Auf einem Mac wählen Sie zuvor Formatvorlage: Klassisch aus.
  6. Tragen Sie als Formel ein =SUMME($B2:$D2)<20

    Formel für zeilenweise bedingte Formatierung
    Die Formel für die zeilenweise bedingte Formatierung
  7. Suche Sie sich für das Formatieren eine Methode aus, um diese Zellen für Ihren Anwendungsfall geeignet hervorheben zu lassen. Hier haben wir eine Blaufärbung des Hintergrunds gewählt.

Das Ergebnis kann dann zum Beispiel so aussehen

Automatische zeilenweise Formatierung bestimmter Zellen

Das ist die Besonderheit der zeilenweisen Formatierung

Die Dollarzeichen vor den Spaltenadressen in der Formatierungsformel sind entscheidend dafür, dass die Formatierung wirklich gleichmäßig auf die ganze Zeile wirkt. Das hängt damit zusammen, wie Excel die Zellbezüge in der Formel für den markierten Bereich nutzt. Denn – ähnlich wie beim Kopieren von Zellen – versucht Excel hier für alle Zellen rechts und unterhalb von der “Startzelle” B2 die verwendeten Zelladressen anzupassen.

Ohne die Dollarzeichen würde Excel zum Beispiel zur Ermittlung der Formatierungsbedingung für die Zelle C2 nicht mehr den Bereich B2 bis D2 nutzen, sondern alles eine Zelle weiter nach rechts rutschen lassen, also die Summe aus C2 bis E2 bilden. Diese unerwünschte Anpassung verhindert das Dollarzeichen.

Die Anpassung in vertikaler Richtung ist dagegen erwünscht. Denn Sie möchten ja für die Frage nach der Markierung des zweiten Tags tatsächlich die Summe über den  zugehörigen Bereich B3 bis D3  bilden lassen. Würden Sie dagegen auch hier Dollarzeichen nutzen, also für die Formatierungsformel =SUMME($B$2:$D$2)<20 einsetzen, dann würde im gesamten Bereich nur die die Zahlen der Zeile 2 ausgewertet werden, also je nach dem Inhalt darin entweder alle Zeilen zusammen gefärbt oder nicht gefärbt erscheinen.

Neugierig geworden? Grundlagen zu den Möglichkeiten für die automatische Formatierung in Excel erfahren Sie in diesem Tipp: Das bietet Ihnen die bedingte Formatierung von Excel

So passen Sie das Prinzip für spaltenweise Formatierung an

Falls Sie eine ganze Spalte oder zumindest einen vertikalen Zellbereich optisch hervorheben möchten, wenn eine bestimmte Bedingung zutrifft, müssen Sie lediglich die Position der Dollarzeichen innerhalb der Bedingungsformel umstellen. Es gehört dann an den zweiten Teil der Zelladressen.

Um beispielsweise zu ermitteln, welcher Mitarbeiter in obigem Beispiel insgesamt weniger als 50 Stunden gearbeitet hat, wäre diese Formatierungsformel hilfreich: =SUMME(B$2:B$8)<50

Schreibe einen Kommentar