Excel: Erläuterung für Formeln durch einen Kommentar

Ohne eine Erläuterung versteht man manche Formel in Excel bald nach dem Verfassen nicht mehr. Damit Sie auch Monate später den Rechenweg noch verstehen, sollten Sie Ihren Formeln einen Kommentar mitgeben. Das können Sie auf zwei Arten erreichen.

So fügen Sie einer Formel eine Erläuterung hinzu

Es gibt aber einen Trick, die Kommentare direkt in die Formeln zu packen, ohne störende Nebeneffekte bei der Berechnung zu erzeugen. Die Basis dazu ist die Funktion N() die für Zeichenketten immer die Zahl 0 zurückliefert, egal welche Parameter ihr übergeben werden. Haben Sie zum Beispiel eine Formel wie

=D18+D19-C5

dann fügen Sie so einen Kommentar hinzu

=D18+D19-C5+N("Grundpreis plus Fracht minus Skonto")

Das Konzept eignet sich auch für mehrere Kommentare, wie etwa hier

=SUMME(B1:B4;N("Quartalsumsätze"))*B5+N("Sonderverkauf")

Sie müssen das N() nur so einbauen, dass sein Ergebnis keine störenden Auswirkungen hat. Sie sollten es also zum Beispiel nicht in einem Produkt verwenden, weil es sonst das Ergebnis zu 0 machen würde.

Bedenken Sie: Wenn Sie einzelnen Zellen oder Bereichen einen Namen geben, hilft das auch schon ungemein, die Formel zu verstehen. Kommentare mittels der Funktion N() sollten Sie nur dann verwenden, wenn Sie irgendeinen Trick anwenden oder eine komplizierte Berechnung nutzen.

So fügen Sie leichter Kommentare in Formeln ein

Bei Tabellen, die nur für Sie selbst gedacht sind, müssen Sie nicht den etwas schwerfälligen Weg gehen, der oben beschrieben ist. Hier verwenden Sie einfach die Kommentarfunktion von Excel:

  1. Klicken Sie mit der rechten Maustaste die Zelle die kommentiert werden soll.
  2. Wählen Sie die Option Kommentar einfügen.

    Excel - Kommentar einfügen
    Über das Kontextmenü oder eine Tastenkombination fügen Sie Kommentare ein, die dann aber für jeden deutlich sichtbar sind.
  3. Um dann den Kommentar zu lesen, genügt es, wenn Sie den Mauscursor über die jeweilige Zelle fahren.

Alternativ erreichen Sie die Kommentarfunktion auch mit der Tastenkombination [Umschalten + F2].



Schreibe einen Kommentar