Excel: Text unscharf vergleichen – Suchmuster, Wildcards und reguläre Ausdrücke verwenden

Oft will man den Inhalt von Zellen nicht auf exakte Inhalte prüfen, sondern mit Suchmustern arbeiten – also etwa ob ein Begriff an beliebiger Stelle in einer Zelle vorkommt. Das geht in Excel recht einfach.

So testen Sie, ob ein Feld einen bestimmten Begriff enthält

    1. Angenommen, Sie möchten in Feld B1 einen Meldungstext ausgeben, wenn die Zelle A1 den Begriff “rund” enthält, egal an welcher Stelle im Text.
    2. Schreiben Sie dazu in B1 folgende Formel
      =WENN(ZÄHLENWENN(A1;"*rund*");"gefunden!";"")
    3. Nun schreiben Sie in A1 zum Beispiel hinein “Baugrundstück” und B1 sollte die Fundmeldung bringen.
    4. Auch “rund” alleine bringt die Erfolgsmeldung, weil der Stern für beliebige Zeichenfolgen inklusive leerer Texte steht.
    5. ZÄHLENWENN() ist die Groß/Kleinschreibung egal. So schlägt die Funktion auch an, wenn in A1 der Text “RUND” steht.

Die Bedingung mit ZÄHLENWENN() können Sie dann an beliebigen Stellen in Excel nutzen, wo die Eingabe von Formeln erlaubt ist – also etwa für die bedingte Formatierung, Damit könnten Sie Zellen optisch hervorheben lassen, wenn sie einem bestimmten Suchmuster entsprechen.

Weitere Tipps für Suchmuster und Wildcards in Vergleichen

  • Obiges Beispiel verwendet den Stern als Platzhalter für beliebige Zeichen vor und nach dem gesuchten Begriff. Den Stern können Sie aber genauso auch inmitten des Suchbegriffs verwenden und nicht zur zu Anfang und Ende wie oben. Würden Sie zum Beispiel als Suchbegriff “BA*UM” einsetzen, dann greift dieser Begriff sowohl bei “Bauzentrum”, als auch bei “Baum”, weil ein Stern auch die  leere Zeichenkette beinhaltet.

    Über die Funktion ZÄHLENWENN() suchen Sie in Excel mit Platzhaltern.
  • Neben dem Stern gibt es auch noch das Fragezeichen als Suchhilfe. Das steht für ein einzelnes, beliebiges Zeichen. Würden Sie zum Beispiel prüfen wollen, ob ein Feldinhalt aus den beiden Zeichen “DE” gefolgt von drei beliebigen Zeichen besteht, könnten Sie als zweiten Parameter für ZÄHLENWENN() verwenden “DE???”. Der Vergleich ergäbe dann etwa mit dem Feldinhalten “DE123” oder “Deutz” ein positives Ergebnis.
  • Der Suchparameter von ZÄHLENWENN() kann auch eine zusammengesetzte Zeichenkette sein. Möchten Sie etwa prüfen lassen, ob der Inhalt der Zelle A1 an beliebiger Stelle der Zelle B1 vorkommt, verwenden Sie folgende Formel:
    =ZÄHLENWENN(B1;"*" & A1 & "*")
  • Möchten Sie nach dem Stern oder dem Fragezeichen als Inhalt einer Zelle suchen, dann stellen Sie dem Zeichen eine Tilde (~)  voran. Daran erkennt Excel, dass Sie das jeweilige Zeichen nicht als Wildcard-Symbol, sondern als das Zeichen selbst betrachtet haben möchten.

Darum eignet sich ZÄHLENWENN() auch für die Ähnlichkeitssuche

Wir nutzen in den Beispielen die Funktion ZÄHLENWENN() anders, als eigentlich vorgesehen. Denn sie dient ursprünglich dem Zweck, zu zählen, wie viele Zellen eines Bereiches einer Bedingung entsprechen. Das ist beispielsweise praktisch, um zu erfahren wie viele Monate in einer Umsatzübersicht einen Überschuss in den Einnahmen haben. Dazu kann man ihr als zweiten Parameter neben Textfragmenten und Wildcard-Zeichen auch Bedingungen vorgeben, wie etwa “>0”, womit numerische Zellwerte darauf geprüft werden, ob sie einen positiven Wert besitzen.

Auf einer einzigen Zelle angewandt, liefert ZÄHLENWENN() das Ergebnis 0, wenn der Vergleich fehlschlägt und 1, falls er zutrifft. Die beiden Werte 0 und 1 entsprechen bei Excel (und in vielen anderen Systemen) aber genau den logischen Bedingungen FALSCH und WAHR, so dass das gewünschte Ergebnis herauskommt.

Mit ZÄHLENWENN() können Sie übrigens auch einfach ermitteln, wie viele Zellen eines Bereiches mit Inhalt gefüllt sind.

Besser als einfache Suchmuster – So nutzen Sie Reguläre Ausdrücke

Ein Regulärer Ausdruck, englisch “regular expression” oft abgekürzt mit “regex”, bietet Suchoptionen, die weit über das hinausgehen, was mit der Funktion ZÄHLENWENN() möglich ist. So könnten Sie damit beispielsweise die syntaktische Korrektheit einer eingegebenen Email-Adresse überprüfen lassen oder spezielle Formatvorgaben testen, wie etwa ob an einer bestimmten Stelle im Feld Ziffern vorkommen.

So verbreitet das Konzept der regulären Ausdrücke auch ist – in Excel fest eingebaut ist es nicht (Word übrigens kennt Regex durchaus). Um die mächtigen Suchfunktionen dennoch nutzen zu können, müssen Sie den Umweg über VBA gehen. Dort können Sie eine Regex-Bibliothek aktivieren und die gewünschten Regulären Ausdrücke dann in selbstgeschriebenen VBA-Funktionen verwenden. Diese Funktionen lassen sich dann auch in Excel-Zellfunktionen einsetzen.

Mehr zur Aktivierung der VBA-Bibliothek für reguläre Ausdrucke sowie einige beispielhafte Anwendungen finden Sie in diesem englischen Forumsbeitrag auf Stackoverflow.

Schreibe einen Kommentar