So zeigt Excel doppelte Werte in einer Tabelle an

In vielen Listen möchten Sie doppelte Einträge  vermeiden, weil sie meistens Fehleingaben hinweisen, die unerwünschte Dubletten erzeugen. Excel bietet Ihnen zwei Ansätze, das Problem zu lösen.

So machen Sie doppelte Einträge sichtbar

  1. Markieren Sie den gewünschten Datenbereich.
  2. Gehen Sie zum Ribbon Start
  3. Rufen Sie dort die Schaltfläche Bedingte Formatierung auf.
  4. Wählen Sie aus der erscheinenden Liste den Punkt Regeln zum Hervorheben von Zellen – Doppelte Werte auf

    Excel Doppelte Werte erkennen
    Die Bedingte Formatierung von Excel besitzt eine vordefinierte Regel zur Erkennung von Dubletten.

  5. Lassen die Voreinstellung Doppelte der linken Listbox und suchen sich aus der rechten Auswahl eine passende Formatierung für Dubletten aus.

    Excel - Beispiel fuer Doppelte Werte
    So formatiert Excel die mehrfache vorkommenden Einträge.

Möchten Sie unterschiedliche Farben für die Anzahl der Mehrfachnennungen erreichen, müssen Sie eigene Regeln definieren.

So erzeugen Sie verschiedene Farben, je nach Häufigkeit der Nennung

Mit drei Regeln für die bedingte Formatierung erzeugen Sie eine Hervorhebung wie in folgendem Beispiel, das Vorräte auflistet. Eindeutige Einträge erscheinen hier grün. Kommt ein Name doppelt vor, wird er gelb formatiert, noch häufigeres Auftreten führt zu oranger Markierung. Weil die Formatierung dynamisch ausgewertet wird, erkennen Sie sofort nach der Eingabe neuer Daten, mit welcher Häufigkeit der neue Begriff auftaucht.

Excel Anzahl Einträge zählen
Excel Anzahl Einträge zählen

Um diese Formatierung zu erreichen, gehen Sie so vor:

  1. Markieren Sie den Wertebereich B3 bis C9 von links oben nach rechts unten.
  2. Gehen Sie auf Bedingte Formatierung wie zuvor, wählen aber Neue Regel.
  3. Verwenden Sie den letzten Punkt der Liste Formel zur Ermittlung der zu formatierenden Zellen verwenden.
  4. Geben Sie als Formel ein =ZÄHLENWENN($B$3:$B9;$B3)=1 

    Excel Formatierung für einmalige Werte
    Die erste Bedingte Formatierung zeichnet alle Werte aus, die eindeutig sind, also nicht mehrfach vorkommen,

  5. Weisen Sie dieser Formatierung die grüne Füllfarbe zu.
  6. Legen Sie noch zwei weitere Regeln an:
  7. Gelb erscheint bei: =ZÄHLENWENN($B$3:$B9;$B3)=2
  8. Orange Färbung soll für den Fall eintreten, dass diese Formel zutrifft: =ZÄHLENWENN($B$3:$B9;$B3)>2

Die Funktion ZÄHLENWENN() prüft, wie oft ein Wert in einem bestimmten Bereich vorkommt. Der Bereich ist hier durch Verwendung der Dollar-Notation absolut festgelegt. Die Zelle mit dem Vergleichswert dagegen hat relativen Bezug bei der Zeile, so dass in jeder Zeile das Vorkommen des Wertes in Spalte B im gesamten Bereich gezählt wird und die Formatierung entsprechend erscheint.

Weil Excel seit Version 2007 nicht auf 3 Formatierungsregeln beschränkt ist, wie seine Vorgänger, können Sie nahezu beliebig viele solche optische Auszeichnungen für eine bestimmte Häufigkeit festlegen.

Die erste bedingte Formatierung könnten Sie natürlich auch weglassen. Dann haben die Zellen mit eindeutigem Inhalt einfach den normalen Hintergrund.

Übrigens: Die Bedingte Formatierung können Sie auch prima dafür verwenden, Felder hervorzuheben, die Benutzereingaben enthalten.

Halt die Klappe, Alexa! 😤

So, Schluss, aus. Alexa ist abgestöpselt. Stecker aus der Dose, ab ins Regal. Warum? Weil mir das Amazon Echo dauernd reinquatscht. Und weil es mich nicht versteht.

Warum ich von einem simplen „Plop“ so begeistert bin 🎛

VCV-Rack

Ok, es ist mehr, als ein „Plop“ – es ist auch ein „Wi-UUU-Wi-UUU“ und so vieles mehr. Ich spreche von einem modularen Synthesizer. Fast hätte ich mir so ein Ding als Hardware gekauft für über 500 Euro. Doch dann habe ich ein Programm entdeckt, das einen modularen Synthesizer auf dem Computer simuliert.