Terminplanung mit Excel: Termine mit Farbe hervorheben

Wenn Sie in Excel die in Kürze anstehende Termine hervorheben möchten, ist eine abgestufte farbige Hinterlegung praktisch. Damit werden die dringlicheren Ereignisse auffällig markiert. Hier lesen Sie, wie Sie das ganz einfach Ihre Terminliste einbauen.

So ermitteln Sie die Tage bis zum jeweiligen Termin

  1. Sehen Sie sich folgende einfache Liste an. In der Spalte A sind verschiedene Datumswerte eingetragen.

    Terminliste Aufbau
    Das ist der Aufgangspunkt für Ihre Terminübersicht.

  2. Legen Sie in Spalte B neben jedem Termin eine Zelle an, die die Anzahl der ausstehenden Tage bis zum jeweiligen Datum ermittelt. Das ist ein guter Ausgangspunkt für die Farbmarkierung.
  3. Es soll also die Differenz des eingetragenen und des heutigen Datums berechnet werden, dazu schreiben Sie in das Feld B2 folgende Formel: =A2-HEUTE()
  4. Als Ergebnis werden Sie anstatt einer Zahl allerdings ein Datum im Jahr 1900. Das kommt daher, dass Excel das Feld B2 automatisch als Datum umformatiert.
  5. Um das zu ändern, ändern Sie in der Menüleiste die Formatierung von Datum zu Standard. Nun sehen Sie die gewünschte Differenz in Tagen.
  6. Kopieren Sie die Formel und die Formatierung in die Zellen unterhalb von B2 indem Sie das kleine Quadrat im Zellrahmen von B2 nach unten ziehen.

    Terminliste mit Differenz in Tagen
    Die Liste wurde mit einer Spalte für die Tage bis zum genannten Termin ergänzt.

Nun erhalten Sie die Liste der Tage bis zum jeweiligen Termin. Negative Zahlen bedeuten, dass er überfällig ist. Für einen bereits abgeschlossenen Termin ist diese Anzeige einer negativen Restzeit natürlich unschön. Darum stellen Sie das im nächsten Schritt ab.

So markieren Sie einen Termin als erledigt

Die Spalte C soll Vermerke für erledigte Termine tragen. Damit ein Eintrag hier Auswirkungen auf die Restanzeige in Spalte B hat, ergänzen Sie die Formel um eine Fallunterscheidung: Falls C2 leer ist, wird die Restzeit berechnet wie zuvor, ein Vermerk in Spalte C deaktiviert die Anzeige der restlichen Tage.

  1. Ändern Sie die Formel in B2 so ab: =WENN(C2=””;A2-HEUTE();””)
  2. Probieren Sie es aus und schreiben in C2 “erledigt” oder “ok” hinein. Die Zelle B2 sollte daraufhin keinen Zahlenwert mehr erhalten, sondern leer sein.
  3. Nun klicken Sie mit der Maus wieder das kleine Quadrat rechts unten an der markierten Zelle B2 an und ziehen es bis zur letzten Zeile der Liste, um die geänderte Formel zu vervielfältigen.

    Terminliste mit Vermerk
    De Liste hat nun eine Möglichkeit erhalten, einen Vermerk für erledigte Termine abzulegen,

So heben Sie bald anstehende Termine hervor

Markieren Sie nun die Zellen mit Werten in der der Resttage-Spalte, also B2 bis B7.

Gehen Sie zur Schaltfläche Bedingte Formatierung und wählen bei Farbskalen den allerersten Eintrag aus.

Nun wird die Spalte B schon eingefärbt, allerdings noch auf einer falschen Berechnungsbasis. Denn Excel teilt in der Grundeinstellung die Werteliste der Resttage in Minimum und Maximum auf und sorgt für eine gleichmäßige Farbverteilung.

Bei Bedarf können Sie übrigens auch die jeweilige Kalenderwoche in Ihre Tabellen bringen, müssen Sie die

So legen Sie individuelle Regeln für die Färbung fest

Üblicherweise haben Sie aber andere Wünsche, etwa dass alles, was heute fällig ist, rot sein soll. Gelb ist für Termine gedacht, die in 3 Tagen anstehen.  Alles, was 14 Tage oder länger in der Zukunft liegt, kommt in harmlosem Grün daher. Diese Regel teilen Sie nun Excel mit:

  1. Dazu lassen Sie B2 bis B7 markiert und gehen bei Bedingte Formatierung auf den Eintrag Regeln verwalten.
  2. Nun sollten Sie eine Übersicht der Regeln sehen, die nur aus einem Eintrag für die zuvor angelegte Regel besteht. Klicken Sie diesen Eintrag doppelt an, um ihn zu ändern.
  3. Ändern Sie die Werte in den sechs Eingabefeldern wie folgt ab, um die gewünschte Färbung zu erhalten:

    Formatierungsregel für die Terminliste
    Mit dieser Regel lassen Sie bald anstehende Termine auffällig hervorheben.

  4. Wenn Sie die Änderung der Formatierungsregel bestätigen und das Verwaltungsfenster schließen, sollte Excel die Termine wie gewünscht farbig markieren:

    Terminliste mit farbigen Markierungen
    Nun sehen Sie anhand der Farbmarkierung, was demnächst fällig wird.

So rechnen Sie mit Arbeitstagen

Durch die Datumsrechnung in obiger Formel berücksichtigt die Tabelle keine Wochenenden. Wenn es bei Ihrem Fall zum Beispiel um das Erledigen von Projekten geht, helfen Ihnen diese Zahlen also nicht viel weiter, sondern Sie brauchen die effektiven Arbeitstage bis zum Stichtag.

Das ist in Excel kein Problem. Sie müssen nur eine andere Methode verwenden, um die Datumsdifferenz zu ermitteln. Verwenden Sie die Funktion Nettoarbeitstage(), um in reinen Arbeitstagen zu rechnen.

Hier die komplette neue Formel für die Zelle B2: =WENN(C2=””;NETTOARBEITSTAGE(HEUTE();A2);””)

Die Formeln kopieren Sie dann wieder durch Ziehen am Quadrat nach unten, um die erste Version der Berechnung zu ersetzen.

Die Methode ähnelt der aus dem Tipp So ermitteln Sie in einer Excel-Personenliste, wer heute Geburtstag hat. Im Unterschied zur Geburtstagsliste kehren die Termine aber nicht jährlich wieder.

Sie können sich das fertige Beispiel auch herunterladen.

Halt die Klappe, Alexa! 😤

So, Schluss, aus. Alexa ist abgestöpselt. Stecker aus der Dose, ab ins Regal. Warum? Weil mir das Amazon Echo dauernd reinquatscht. Und weil es mich nicht versteht.

Warum ich von einem simplen „Plop“ so begeistert bin 🎛

VCV-Rack

Ok, es ist mehr, als ein „Plop“ – es ist auch ein „Wi-UUU-Wi-UUU“ und so vieles mehr. Ich spreche von einem modularen Synthesizer. Fast hätte ich mir so ein Ding als Hardware gekauft für über 500 Euro. Doch dann habe ich ein Programm entdeckt, das einen modularen Synthesizer auf dem Computer simuliert.